The purpose of this document is to explain the steps required to install and configure the COINCOMO 2.0 tool on supported systems.
Copyright Notice
This document is copyrighted, and all rights are reserved by the University of Southern California (USC). This document may not, in whole, or in part, be copied, photocopied, reproduced, translated, or reduced to any electronic medium or machine readable form without prior consent.

Copyright© 1995-2013 University of Southern California

All rights reserved.

Warranty
This manual is provided “as is” without warranty of any kind, either express or implied, including, but not limited to the implied warranties of merchantability and fitness for a particular purpose. Moreover, USC reserves the right to revise this manual and to make changes periodically without obligation to notify any person or organization of such revision or changes.

Trademark Acknowledgment
USC has made every effort to supply trademark information about company names, products, and services mentioned in this document. Trademarks indicated below were derived from various sources.

UNIX is a registered trademark of AT&T Bell Laboratories

Java is a registered trademark of Oracle Corporation

MS Windows95, Windows98, WindowsNT, Windows XP, Windows Vista, Windows 7, and Windows 8 are trademarks of the Microsoft Corporation

Some of the material used in this manual has been taken from the book Software Engineering Economics, written by Barry Boehm and published by Prentice-Hall, with permission of the author.

Printed in the United States of America
## Version History

<table>
<thead>
<tr>
<th>Date</th>
<th>Author</th>
<th>Version</th>
<th>Changes Made</th>
<th>Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>07/16/2009</td>
<td>Sagar K.</td>
<td>0.10</td>
<td>• Document created</td>
<td>• First draft</td>
</tr>
<tr>
<td>08/06/2009</td>
<td>Sagar K.</td>
<td>0.11</td>
<td>• Added Copyright Notice</td>
<td>• Commercial installations to be covered in a separate guide</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Made changes to Section 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Installation now referred to as Standalone</td>
<td></td>
</tr>
<tr>
<td>01/18/2013</td>
<td>Larry C.</td>
<td>0.12</td>
<td>• Modified the contents to fit with the version of COINCOMO that is to be released to affiliates.</td>
<td>• Corrections</td>
</tr>
<tr>
<td>02/22/2013</td>
<td>Larry C.</td>
<td>0.13</td>
<td>• Correction of trademarks</td>
<td>• Corrections</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Added 64-bit support remarks for Window 7/Vista</td>
<td></td>
</tr>
<tr>
<td>03/01/2013</td>
<td>Larry C.</td>
<td>1.0</td>
<td>• Modified the URLs for COINCOMO related files/documentations.</td>
<td>• Corrections for initial release</td>
</tr>
</tbody>
</table>
# Table of Contents

*Copyright Notice* ............................................................................................................................................. 2  
*Version History* .............................................................................................................................................. 3  
*Table of Contents* ........................................................................................................................................... 4  
1. *Introduction* .................................................................................................................................................. 5  
2. *System Requirements* .................................................................................................................................... 5  
3. *Installation and Configuration of COINCOMO 2.0* .................................................................................. 5  
   3.1. *Overview* ................................................................................................................................................ 5  
   3.2. *Linux* ...................................................................................................................................................... 6  
   3.3. *Windows* ............................................................................................................................................... 9  
   3.4. *Mac OS X* .......................................................................................................................................... 12  
*Appendix A. Sample Installation on Windows* ........................................................................................... 16
1. Introduction
COINCOMO 2.0 (Constructive INcremental COst Model 2.0) is a software estimation tool developed by the Center for Systems and Software Engineering at the University of Southern California. It allows one to estimate the cost, effort and schedule when planning a new software development activity.

2. System Requirements
Minimum system requirements: IBM/IBM-compatible PC, 700 MHz Intel or equivalent microprocessor, 512 MB RAM, 1 GB hard disk space.
Recommended system requirements: IBM/IBM-compatible PC, 1 GHz Intel or equivalent microprocessor, 1 GB RAM, 2 GB hard disk space.


3. Installation and Configuration of COINCOMO 2.0
3.1. Overview
Installation and configuration of the COINCOMO 2.0 estimation tool on a standalone system follows these steps:
1. Installation of Java Runtime Environment (JRE)
2. [Optional] Installation of PostgreSQL (PGSQL)
3. [Optional] Creation and configuration of the COINCOMO database (DB)
4. Installation of the COINCOMO 2.0 software tool
5. Verification of COINCOMO 2.0

– Here, ‘Optional’ refers to the fact that COINCOMO 2.0 has several editions (Desktop Edition, Database Edition, and Unified Edition). Database Edition requires these steps to be performed in order to work, while Unified Edition requires these steps to be performed if it is to run in Database Mode.
These steps are differently executed depending upon the host operating system. We, therefore, discuss the installation and configuration of COINCOMO 2.0 separately for each platform in the following sub-sections. Users must refer to the appropriate sub-section according to their operating system.

### 3.2. Linux

The procedure to install COINCOMO on Linux systems is described below.

1. **COINCOMO 2.0 requires Java Runtime Environment (JRE) version 1.6 (also known as Java 6) or newer to operate on a system.** If the JRE does not already exist in the system the users will run COINCOMO on, they will need download and install JRE. These downloads can be obtained at the following URLs –
   - [https://help.ubuntu.com/community/Java](https://help.ubuntu.com/community/Java)

   Installation instructions and system requirements for installation of the JRE are available at the following URLs –

2. **[Optional]** COINCOMO 2.0 Database Edition stores all project-related data estimates in an underlying database, and COINCOMO 2.0 Unified Edition can run under Database Mode to store the same information in the database. Although any database could theoretically be used for storing such data, the initial release of COINCOMO 2.0 only supports PostgreSQL (PgSQL), an Open-Source Object-Relational Database Management System that is widely used by the academic community as also by commercial enterprises. MySQL support is in the pipeline.

   PostgreSQL version 9.x binaries for Linux can be downloaded from the URL
   - [http://www.postgresql.org/download/](http://www.postgresql.org/download/). Appropriate installation documentation can also be found on this site by following the links for the Linux binaries. The most current documentation for installation of PostgreSQL on Linux systems can be found at the URL
   - [http://www.postgresql.org/docs/current/static/installation.html](http://www.postgresql.org/docs/current/static/installation.html). Alternatively, one-click installers
are also available for Linux systems, with the appropriate documentation located at the URL http://www.enterprisedb.com/resources-community/pginst-guide.

A typical PostgreSQL setup installs, among other things, a core database server with complete documentation, one or more server-side procedural languages, and popular command-line tools and several add-on packages.

3. [Optional] Once the PostgreSQL database server is installed, the next step is to create a specific database needed for the COINCOMO tool itself. On Linux systems, first ensure that the database server is running. This can be done using the command:

```bash
$ netstat | grep <pgsql_portno>
```

where `<pgsql_portno>` is the port number specified during the installation of PostgreSQL. By default the `<pgsql_portno>` port number is 5432. This port is used by the server to listen for incoming database connections. Alternatively, the following command can also show whether the database server is running:

```bash
$ ps [switches] | grep postgres
```

Refer the appropriate documentation to include the switches in the above command. Once the server is running, the following simple shell command should be sufficient to create the COINCOMO database:

```bash
$ <PostgreSQL_Installation_Path>/bin/createdb <database_name>
```

where `<PostgreSQL_Installation_Path>` refers to the installation directory of the PostgreSQL RDBMS, and `<database_name>` refers to the name given to the COINCOMO database and should be COINCOMO by default. By default the `<PostgreSQL_Installation_Path>` directory should be similar to `/usr/lib/postgresql/9.x` (the default directory when installed on Ubuntu Linux using `apt-get` command method).
Alternatively, the pgAdmin III database management utility can also be used to create a new
database, as follows:

a) Click on Applications → PostgreSQL 9.x → pgAdmin III.

b) The pgAdmin III tool should show your default PostgreSQL server in its Object Browser. Right-
click on the server and click on ‘Connect’. Enter the default password for the “postgres” user
when prompted (the user “postgres” and one database “postgres” are created by default when
PostgreSQL is installed).

In the Object Browser, collapse the object tree, right-click on ‘Databases’ and click on ‘New
Database’. Enter “COINCOMO” as the name of the database in the dialog box, and click on ‘OK’.

Further configuration of the COINCOMO database is achieved using the COINCOMO database script
available for download from the URL http://csse.usc.edu/tools/COINCOMO/postgres_sql.zip. There
is only one script within the ZIP archive:

1) coincomo_all_in_one_postgres.sql – deletes existing tables and functions in the COINCOMO
database if necessary, and then creates new tables and functions that COINCOMO 2.0 tool
depends on.

The following shell command should be used to execute the script:

\$ <PostgreSQL_Installation_Path>/bin/psql -f <scriptname> <database_name>

4. The COINCOMO 2.0 tool is available for download from the URL
   http://csse.usc.edu/tools/COINCOMO/. Download any of the three editions of COINCOMO 2.0. The
   one-click installer for the tool is the “Coincomo_unix_2.0_<edition>.sh” file. Execute/run the one-
   click installer and an installer screen will appear. Follow the instructions on the screen to install the
   COINCOMO 2.0 tool.

5. To verify the installation and correct operation of COINCOMO 2.0, the user should perform the
   following exercise:

   1) Change to the COINCOMO installation directory

   2) Launch the COINCOMO 2.0 tool by typing the following command at the prompt
$ ./COINCOMO\ 2.0
3) [Optional] Click on File \rightarrow Connect
4) [Optional] Enter the credentials of the user “postgres” when prompted
5) Click on File \rightarrow New Project...
6) Change the system name to “TestSystem”
7) Right-click on TestSystem and click on ‘Add Sub System’
8) Change the sub system name to “TestSubSystem”
9) Right-click on TestSubSystem and click on ‘Add Component’
10) Change the component name to “TestComponent”
11) In the main window, create a new subcomponent and change its name to “TestSubComponent”
12) Select TestSubComponent, click on the corresponding ‘Size’ column and assign 10,000 as new SLOC; click ‘Apply’ and ‘Close’
13) Notice that the estimation section will reflect the cost estimation corresponding to the 10,000 SLOC
14) In the main window, change to the ‘COPSEMO’ tab and notice that the effort and schedule is automatically calculated for the 10,000 SLOC
15) Click on File \rightarrow Export \rightarrow Export as CSV...
16) Rename and save the CSV file; notice that two separate CSV files are created

3.3. Windows
The procedure to install COINCOMO on Windows systems is described below.

1. COINCOMO 2.0 requires Java Runtime Environment (JRE) version 1.6 (also known as Java 6) or newer to operate on a system. If the JRE does not already exist in the system the users will run COINCOMO on, they will need download and install JRE. These downloads can be obtained at the URL http://www.java.com/en/download/manual.jsp.
   Installation instructions and system requirements for installation of the JRE are available at the URL http://www.java.com/en/download/help/windows_offline_download.xml.
2. **[Optional]** COINCOMO 2.0 Database Edition stores all project-related data estimates in an underlying database, and COINCOMO 2.0 Unified Edition can run under Database Mode to store the same information in the database. Although any database could theoretically be used for storing such data, the initial release of COINCOMO 2.0 only supports PostgreSQL (PgSQL), an Open-Source Object-Relational Database Management System that is widely used by the academic community as also by commercial enterprises. MySQL support is in the pipeline.

PostgreSQL version 9.x binaries for Windows can be downloaded from the URL http://www.postgresql.org/download/windows/. A one-click PostgreSQL installer is available for Windows systems; it is recommended that this installer be used for ease of installation. Appropriate installation documentation regarding this one-click installer can be found at the URL http://www.enterprisedb.com/resources-community/pginst-guide. Users interested in installing PostgreSQL from source code can refer to the URL http://www.postgresql.org/docs/current/static/installation.html.

A typical PgSQL setup installs, among other things, a core database server with complete documentation, one or more server-side procedural languages, and popular command-line tools and several add-on packages.

3. **[Optional]** Once the PostgreSQL database server is installed, the next step is to create a specific database needed for the COINCOMO 2.0 tool itself. The COINCOMO database script needs to be downloaded and extracted from the URL http://csse.usc.edu/tools/COINCOMO/postgres_sql.zip before continuing. The pgAdmin III database management utility can be used to create a new database, as follows:
   a) Click on Start Menu → All Programs → PostgreSQL 9.x → pgAdmin III.
   b) The pgAdmin III tool should show your default PostgreSQL server in its Object Browser. Right-click on the server and click on ‘Connect’. Enter the default password for the “postgres” user when prompted (the user “postgres” and one database “postgres” are created by default when PostgreSQL is installed).
c) In the Object Browser, collapse the object tree, right-click on ‘Databases’ and click on ‘New Database’. Enter “COINCOMO” as the name of the database in the dialog box, and click on ‘OK’.

d) In the Object Browser, expand the object tree, click on the + square next to Databases to see a list of databases.

e) Double-click on the database COINCOMO to select it.

f) From menu, click Tools → Query tool or press Ctrl-E. A query window will appear over pgAdmin III.

g) From the query window, click File → Open... from menu or press Ctrl-O.

h) Navigate to the database script extracted and open it in the query window.

i) Still at the query window, click Query → Execute from menu or press F5 twice. This is to ensure the possible errors from the first run are cleared.

j) In the Output pane, from the Messages tab, scroll down to the last lines of text to make sure the query finished successfully without errors. Now the database is ready for COINCOMO 2.0 tool.

4. The COINCOMO 2.0 tool is available for download from the URL http://csse.usc.edu/tools/COINCOMO/. Download any of the three editions of COINCOMO 2.0. The one-click installer for the tool is the “Coincomo_windows_2_0_<edition>.exe” file. Double-click the one-click installer and an installer screen will appear. Follow the instructions on the screen to install the COINCOMO 2.0 tool.

5. To verify the installation and correct operation of COINCOMO 2.0, the user should perform the following exercise:

   1) Launch the COINCOMO tool by clicking on Start Menu → All Programs → COINCOMO →
      COINCOMO 2.0 → COINCOMO 2.0

   2) [Optional] Click on File → Connect

   3) [Optional] Enter the credentials of the user “postgres” when prompted

   4) Click on File → New Project...

   5) Change the system name to “TestSystem”

   6) Right-click on TestSystem and click on ‘Add Sub System’

   7) Change the sub system name to “TestSubSystem”
8) Right-click on TestSubSystem and click on ‘Add Component’
9) Change the component name to “TestComponent”
10) In the main window, create a new subcomponent and change its name to “TestSubComponent”
11) Select TestSubComponent, click on the corresponding ‘Size’ column and assign 10,000 as new SLOC; click ‘Apply’ and ‘Close’
12) Notice that the estimation section will reflect the cost estimation corresponding to the 10,000 SLOC
13) In the main window, change to the ‘COPSEMO’ tab and notice that the effort and schedule is automatically calculated for the 10,000 SLOC
14) Click on File → Export → Export as CSV…
15) Rename and save the CSV file; notice that two separate CSV files are created

3.4. Mac OS X
The procedure to install COINCOMO on Mac OS X systems is described below.

1. COINCOMO 2.0 requires Java Runtime Environment (JRE) version 1.6 (also known as Java 6) or newer to operate on a system. If the JRE does not already exist in the system the users will run COINCOMO on, they will need download and install JRE. These downloads can be obtained at the URL http://www.java.com/en/download/manual.jsp. Installation instructions and system requirements for installation of the JRE are available at the URL http://www.java.com/en/download/help/mac_install.xml.

2. [Optional] COINCOMO 2.0 Database Edition stores all project-related data estimates in an underlying database, and COINCOMO 2.0 Unified Edition can run under Database Mode to store the same information in the database. Although any database could theoretically be used for storing such data, the initial release of COINCOMO 2.0 only supports PostgreSQL (PgSQL), an Open-Source Object-Relational Database Management System that is widely used by the academic community as also by commercial enterprises. MySQL support is in the pipeline.
PostgreSQL version 9.x binaries for Mac OS X can be downloaded from the URL http://www.postgresql.org/download/macosx/. A one-click PostgreSQL installer is available for Mac OS X systems; it is recommended that this installer be used for ease of installation. Appropriate installation documentation regarding this one-click installer can be found at the URL http://www.enterprisedb.com/resources-community/pginst-guide. Users interested in installing PostgreSQL from source code can refer to the URL http://www.postgresql.org/docs/current/static/installation.html.

A typical PgSQL setup installs, among other things, a core database server with complete documentation, one or more server-side procedural languages, and popular command-line tools and several add-on packages.

3. [Optional] Once the PostgreSQL database server is installed, the next step is to create a specific database needed for the COINCOMO 2.0 tool itself. The COINCOMO database script needs to be downloaded and extracted from the URL http://csse.usc.edu/tools/COINCOMO/postgres_sql.zip before continuing. The pgAdmin III database management utility can be used to create a new database, as follows:
   a) Click on Start Menu → All Programs → PostgreSQL 9.x → pgAdmin III.
   b) The pgAdmin III tool should show your default PostgreSQL server in its Object Browser. Right-click on the server and click on ‘Connect’. Enter the default password for the “postgres” user when prompted (the user “postgres” and one database “postgres” are created by default when PostgreSQL is installed).
   c) In the Object Browser, collapse the object tree, right-click on ‘Databases’ and click on ‘New Database’. Enter “COINCOMO” as the name of the database in the dialog box, and click on ‘OK’.
   d) In the Object Browser, expand the object tree, click on the + square next to Databases to see a list of databases.
   e) Double-click on the database COINCOMO to select it.
   f) From menu, click Tools → Query tool or press Ctrl-E. A query window will appear over pgAdmin III.
   g) From the query window, click File → Open… from menu or press Ctrl-O.
h) Navigate to the database script extracted and open it in the query window.

i) Still at the query window, click Query → Execute from menu or press F5 twice. This is to ensure the possible errors from the first run are cleared.

j) In the Output pane, from the Messages tab, scroll down to the last lines of text to make sure the query finished successfully without errors. Now the database is ready for COINCOMO 2.0 tool.

4. The COINCOMO 2.0 tool is available for download from the URL http://csse.usc.edu/tools/COINCOMO/. Download any of the three editions of COINCOMO 2.0. The one-click installer for the tool is the “Coincomo_macos_2_0_<edition>.exe” file. Double-click the one-click installer and an installer screen will appear. Follow the instructions on the screen to install the COINCOMO 2.0 tool.

5. To verify the installation and correct operation of COINCOMO 2.0, the user should perform the following exercise:

1) Launch the COINCOMO tool from Finder → Applications → COINCOMO → COINCOMO 2.0

2) [Optional] Click on File → Connect

3) [Optional] Enter the credentials of the user “postgres” when prompted

4) Click on File → New Project...

5) Change the system name to “TestSystem”

6) Right-click on TestSystem and click on ‘Add Sub System’

7) Change the sub system name to “TestSubSystem”

8) Right-click on TestSubSystem and click on ‘Add Component’

9) Change the component name to “TestComponent”

10) In the main window, create a new subcomponent and change its name to “TestSubComponent”

11) Select TestSubComponent, click on the corresponding ‘Size’ column and assign 10,000 as new SLOC; click ‘Apply’ and ‘Close’

12) Notice that the estimation section will reflect the cost estimation corresponding to the 10,000 SLOC

13) In the main window, change to the ‘COPSEMO’ tab and notice that the effort and schedule is automatically calculated for the 10,000 SLOC
14) Click on File → Export → Export as CSV...

15) Rename and save the CSV file; notice that two separate CSV files are created
Appendix A. Sample Installation on Windows

This appendix provides a rundown for the installation of COINCOMO 2.0 Database Edition on a PC with a 1.8 GHz Intel Core2 Duo processor, 2 GB RAM and Windows Vista Business 32-bit operating system. Most of the content has been described with the help of screenshots.

Before installation of COINCOMO 2.0 on a PC, it is recommended that the user take a backup of the existing system configuration. For more details, refer to the appropriate operating system release notes.

Note: If your copy of COINCOMO 2.0 is Desktop Edition, you can skip steps 2 and 3 since you will not need to install PostgreSQL and run the database script.

1. **Installation of Java Runtime Environment (JRE)**

2. **Installation of PostgreSQL (PgSQL)**
   Download the one-click installer and install from [http://www.postgresql.org/download/windows](http://www.postgresql.org/download/windows).
   On Windows Vista, the one-click PostgreSQL installer may not install the database correctly due to security issues. A workaround for this problem is to right-click on the one-click installer, choose “Run as administrator” then install PostgreSQL.
Please select a directory under which to store your data.

Data Directory: `C:\Program Files\PostgreSQL\9.0\data`

Please provide a password for the database superuser (postgres) and service account (postgres). If the service account already exists in Windows, you must enter the current password for the account. If the account does not exist, it will be created when you click 'Next'.

Password: *********
Retype password: *********
Setup

Ready to Install

Setup is now ready to begin installing PostgreSQL on your computer.

< Back  Next >  Cancel

Installing

Please wait while Setup installs PostgreSQL on your computer.

Installing

Unpacking C:\Program Files\PostgreSQL\9.0\bin\pg_register_extensions.exe

< Back  Next >  Cancel
Successful installation of PostgreSQL can be verified by observing the log file that is generated by the installer. On Windows Vista, this file is named install-postgresql.log and is located in the C:\Users\<User>\AppData\Local\Temp directory. If any errors are encountered during the installation, they are also recorded in this log file. Users who encounter errors should refer to EnterpriseDB PostgreSQL Forums to find the solution.

On Windows, the PostgreSQL server is installed as a service. Therefore, its status can also be checked by going through Start Menu → Control Panel → System and Administration → Administrative Tools → Services.
3. **Creation and configuration of the COINCOMO database (DB) using custom scripts**

Open pgAdmin III via Start Menu → All Programs → PostgreSQL 9.x → pgAdmin III
Connect to the database server by right-clicking on the server and choose ‘Connect’. Enter the password you typed in duration the installation of PostgreSQL.
Create a new database called COINCOMO by right-clicking on the Databases and choose New Database....

Type in “COINCOMO” for the name of the new database and click the OK button to create the database.
Expand the Databases tree to see the new database COINCOMO.
Connect to the database COINCOMO by clicking on it.
Open the Query tool by pressing Ctrl-E or clicking on the magnifier icon with the word SQL in it, or from the menu Tools → Query tool.

Open the database script mentioned in the installation guide in the Query tool window by clicking on the Open file icon or from menu File → Open....
Run the database script to create the tables and functions required for COINCOMO 2.0 to function by clicking on the Execute query icon or from menu Query → Execute.

From the Messages tab, scroll down to the last few lines of texts to make sure the database script was executed correctly. The last line of text should say something similar to “Query returned successfully with no result in xxx ms.”

Note: The first time the database script is run there might be some error messages that can be ignored due to non-existent types. Running it a second time ensures that the step is completed correctly.

4. **Installation of the COINCOMO 2.0 tool**

   Install COINCOMO 2.0 Database Edition by double-clicking on the one-click installer. Again, on Windows Vista, the one-click installer may require additional security privileges before the installation will proceed. A workaround for this problem is to right-click on the one-click installer, choose “Run as administrator” when trying to install COINCOMO 2.0.
Note: Click Allow if the above screen pops up to continue the installation.
Welcome to the COINCOMO Setup Wizard

This will install COINCOMO on your computer. The wizard will lead you step by step through the installation.

Click Next to continue, or Cancel to exit Setup.

Select Destination Directory
Where should COINCOMO be installed?

Select the folder where you would like COINCOMO to be installed, then click Next.

Destination directory:
C:\Program Files\COINCOMO\COINCOMO 2.0

Required disk space: 4.9 MB
Free disk space: 3,405 MB
Select Start Menu Folder

Where should Setup place the program's shortcuts?

Select the Start Menu folder in which you would like Setup to create the program's shortcuts, then click Next.

- [ ] Create a Start Menu folder
- [ ] Create shortcuts for all users

Install:

< Back  Next >  Cancel

Setup - COINCOMO 2.0

Completing the COINCOMO Setup Wizard

Setup has finished installing COINCOMO on your computer. The application may be launched by selecting the installed icons.

Click Finish to exit Setup.
5. **Verification**

Open COINCOMO 2.0 via Start Menu → All Programs → COINCOMO → COINCOMO 2.0 → COINCOMO 2.0.

![COINCOMO 2.0 Verification](image)

Connect to the database COINCOMO by filling out the username and password then click Connect.
Note: The status bar at the bottom of COINCOMO 2.0 tool should say “Connected to Database.” This means COINCOMO 2.0 has established a working connection to the COINCOMO database.

Verify that COINCOMO 2.0 is working by creating a new project and entering some details. The following screenshots will create a system, a sub system, a component, a sub component, then enter a sample size for the sub component and verify the calculations are performed.
System (System1)'s Overview:
There are currently no sub systems in (System1)

Input

Please enter the new name:
Sample System

OK  Cancel
System Sample System's Overview:

There are currently no Sub systems in Sample System.
Click on the size column for the sub component “Sample Sub Component” to open the Size dialog.
After entering the SLOC for the sub component, click Apply button to confirm the changes. Then close the dialog by clicking the Close button.
You should see that the Estimation panel now has different numbers because COINCOMO 2.0 performed the calculations once the changes are applied. Click on the COPSEMO tab to verify that COPSEMO calculations are performed as well.

Now you should have a working COINCOMO 2.0 installation on your system.